como-instalar-google-play

Utvecklare måste arbeta med minst API-nivå 26, vad betyder detta?

Google implementerar nya säkerhetsfunktioner i alla versioner av Android, men vissa ändringar gäller endast applikationer som är inriktade på nyare API-nivåer. Därför meddelade det amerikanska företaget i slutet av förra året att det avslutar applikationer som skapats för tidigare versioner av Android.

Från och med 1 november 2018, utvecklare kan inte längre lägga upp något på Google Play utan att rikta in sig på minst API-nivå 26, vilket motsvarar Oreo 8.0. Men vad betyder detta och vad påverkar det?

Endast de applikationer som pekar på Android Oreo kan publiceras

För utvecklare är det inget nytt, eftersom Google sedan 1 augusti inte längre har rätt att inkludera fler applikationer med API-nivåer lägre än Oreo. Alla applikationer som finns i Google Play, krävs för att uppdatera med API 26eftersom alla applikationer med detta har säkerhet såsom begränsad åtkomst till användarkonton.

Google-Play-Store-gränssnitt-Material-Design

Program som inte längre stöds kan förbli aktiva med sitt gamla och osäkra API. Men kanske i framtiden kommer den att försvinna om den inte uppdateras från Android-applikationsbutiken.

Miniminivån på API kommer att öka varje år, detta är normalt eftersom ny säkerhet alltid implementeras. Google varnar också för att en framtida version av Android begränsar applikationer som är inriktade på gamla API-nivåer.

Kanske har utvecklarna arbete framåt, men det kommer att gynna användare som använder sina applikationer säkert. Många fel eller fel kommer från det faktum att versionerna är för gamla och inte har korrigerats på länge. Därför bör detta vara en effektiv lösning. | Källa: Android Police